ACU can't find HTM help

No help is currently available for this setting or situation.


ACU Adapter feature tab

Adapter Information Panel:

This panel displays detailed information about the currently selected adapter.

Adapter Settings Panel:

This panel displays the available settings for the adapter. Settings are dependent on the adapter and operating system. Only settings that are available with your adapter/operating system combination are displayed.

Diagnostics Panel:

This panel displays the available tests and test results for the adapter .

Apply Changes: Saves and applies all the changes made since the last save.

Discard Changes: Removes changes since the last save.

Remove Team: Removes the selected team.


ACU Adapter information panel

Adapter Information Panel:

This panel displays detailed information about the currently selected adapter. You cannot modify any settings on this panel.


allow_No_FEC_modules_in_auto

Adds Allow No FEC Modules as a supported mode during FEC autonegotiation.


PTP Hardware Timestamp

Allows applications that use PTPv2 (Precision Time Protocol) to use hardware generated timestamps to synchronize clocks throughout your network.


QoS Offload

Configures the Quality of Service (QoS) offload setting for the miniport adapter. This feature allows you to set a bandwidth cap and reservation to one or more virtual machines on a physical device, including both software VMs and SR-IOV interfaces.


Software Timestamp

Allows applications that use PTPv2 (Precision Time Protocol) to use software generated timestamps to synchronize clocks throughout your network.


Speed & Duplex setting

By default, Intel® devices are set to automatically detect and negotiate speed and duplex settings. If the adapter fails to connect, you can set the speed and duplex settings to match those of the link partner.


adapter recovery mode

This port is in firmware recovery mode. The underlying hardware has been deactivated. Usually this occurs when a firmware update was interrupted. If your firmware update was interrupted, you should attempt to finish the update.

Refer to the Intel® Ethernet Adapters and Devices User Guide for details on firmware recovery mode.


Adaptive Inter-frame Spacing

Compensates for excessive Ethernet packet collisions by dynamically controlling back-to-back timing.

When this feature is enabled, the network adapter dynamically adapts to network traffic conditions. The default setting works best for most computers and networks. In some rare cases you can obtain better performance by changing this setting.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Adaptive Performance Tuning

Sets the number of frames the adapter receives before triggering an interrupt. Under normal operation, the adapter generates an interrupt every time a frame is received.

Move the slider towards Computer Performance to increase the number of frames the adapter receives before generating an interrupt. Doing so improves the computer's performance, but may reduce adapter bandwidth.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Adaptive Technology

Optimizes performance based on the operating system.

To ensure best possible performance, leave Adaptive Technology on.

NOTES:

  • Disable Adaptive Technology when troubleshooting adapter compatibility issues. Disabling Adaptive Technology also disables Transmit Control Blocks and Adaptive Performance Tuning.
  • If you disable this feature, you must enable Adaptive Inter-Frame Spacing.
  • Changing this setting may cause a momentary loss of connectivity.


Adaptive Transmit Threshold

Specifies the number of bytes the adapter stores in its transmit buffer before sending. For example, if the Adaptive Transmit Threshold value is 100, the adapter stores 100 bytes in its buffer before sending the data.

The adapter uses the Adaptive Transmit Threshold value as a starting point only. If the adapter is able to achieve better transmit performance using a lower value, it automatically adjusts to that value.

Recommended Value

If the computer has multiple bus mastering cards or high latency, set this value to 200.
If the computer has a single bus mastering card, set this value to 12.

To configure the adapter to first transmit full Ethernet frames and then adjust for best performance, set this value to 190. If transmit performance drops significantly with a value of 190, set the threshold to 16 and then incrementally increase it.
NOTE: Changing this setting may cause a momentary loss of connectivity.


Coalesce Buffers

Sets number of buffers available for transmit acceleration. Changing this setting can significantly increase transmit performance by enabling the adapter to join data segments before packet transmission.

To enhance performance, the Coalesce Buffers setting must be configured to work with the Transmit Descriptors setting. The Coalesce Buffers setting should be 30 - 50% of the Transmit Descriptors value. If the Coalesce Buffers setting is not modified to match the Transmit Descriptors setting, transmit performance might not be enhanced.

Recommended value 8
NOTE: Changing this setting may cause a momentary loss of connectivity.


Offloading Options

Allows you to specify which offload settings are handled by the adapter rather than the operating system.

Enabling offload settings increases transmission performance, as the adapter hardware is able to perform these tasks faster than the operating system. Offloading also frees up CPU resources.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Performance Options

Configures the adapter to use settings that can improve adapter performance.


Enable PME

Allows the adapter to wake an Advanced Power Management (APM) enabled system from an S5 state. Also, some ACPI systems may be awakened from an S5 state if the system's BIOS supports it.

Disabled | Disables wake-up from an S5 state.
Enabled | Allows wake-up from an S5 state.
OS Controlled | Enables the adapter to use the operating system’s default settings.
NOTE: Changing this setting may cause a momentary loss of connectivity.


Encapsulated Task Offload

Allows you to enable or disable offloading encapsulated packet task processing from the CPU to the device, and select which type of processing to use. These features reduce CPU utilization.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Encapsulated Task Offload

Enables the adapter to perform Network Virtualization using Generic Routing Encapsulation (NVGRE) processing, offloading it from the operating system. This feature reduces CPU utilization.

NOTES:

  • The underlying device for this connection has NIC Paritioning enabled. Encapsulated Task Offload can only be configured on the first partition of the physical port.
  • Changing this setting may cause a momentary loss of connectivity.


Encapsulated Task Offload Properties

Enable Encapsulated Packet Task Offload: Enable or disable the offload of encapsulated packet task processing to the device.

Use NVGRE: Selects Network Virtualization using Generic Routing Encapsulation (NVGRE) for encapsulated packet task processing. NVGRE encapsulates L2 packets for transmission over L3 networks. It leverages the Generic Routing Encapsulation protocol for greater compatibility with existing hardware and software stacks.

Use VXLAN: Selects Virtual Extensible LAN (VXLAN) for encapsulated packet task processing. VXLAN encapsulates L2 packets leveraging standard UDP protocols, allowing an L2 network to be extended over an L3 network. VXLAN may be useful in multi-tenant environments such as cloud service providers where the number of VLANs exceeds the 4094 limit imposed by the 12 bit VLAN ID used in Ethernet data frames.

UDP Destination Port: Enter the port number for the User Datagram Protocol (UDP) destination port. Valid values are 1 to 65535.

NOTES:

  • Changing these settings may cause a momentary loss of connectivity.
  • Not all options are available on all adapter/operating system combinations.


Encapsulated Task Offload

The underlying device is configured in NIC Partitioning (NPar) mode. Network Virtualization using Generic Routing Encapsulation (NVGRE) is not supported with NIC Partitioning. The Encapsulated Task Offload setting is therefore displayed as disabled and cannot be modified.


Encapsulation Overhead

When you attach a Virtual Machine to a tenant overlay network through the Virtual NIC ports on a Virtual Switch, the encapsulation headers increase the Maximum Transmission Unit (MTU) size on the virtual port. The Encapsulation Overhead feature automatically adjusts the physical port's MTU size to compensate for this increase. This setting cannot be changed.


Forward Error Correction Mode

Allows you to set the Forward Error Correction (FEC) mode. FEC improves link stability, but increases latency. Many high quality optics, direct attach cables, and backplane channels provide a stable link without FEC.

NOTE: For devices to benefit from this feature, link partners must have FEC enabled.


Flow Control is Disabled

Link Flow Control is disabled because Priority Flow Control has been enabled. Priority Flow Control is automatically enabled when you enable Data Center Bridging (DCB).


Flow control unavailable - NPAR

 The underlying device for this connection has NIC Paritioning enabled. Flow Control can only be configured on the first partition of the physical port. Click the Properties button to open the Property Sheet for the first partition.


Flow Control Settings

Enables adapters to generate or respond to flow control frames, which help regulate network traffic.For an overview of this feature, click here.

Tx Enabled | The adapter pauses transmission when it receives a flow control frame from a link partner.
Rx Enabled | The adapter generates a flow control frame when its receive queue reaches a pre-defined limit.
Rx & Tx Enabled | The adapter generates and responds to flow control frames.
Disabled | The adapter does not generate or respond to flow control frames.

NOTES:

  • For adapters to benefit from this feature, link partners must support flow control frames.
  • Changing this setting may cause a momentary loss of connectivity.
  • This setting cannot be modified from Rx & Tx Enabled if Data Center Bridging (DCB) is enabled.


Giant Send Offload v4

Sets the adapter to offload the task of segmenting TCP messages into valid Ethernet frames. Because the adapter hardware is able to complete data segmentation much faster than operating system software, this feature may improve transmission performance. In addition, the adapter uses fewer CPU resources.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Giant Send Offload v6

Sets the adapter to offload the task of segmenting TCP messages into valid Ethernet frames. Because the adapter hardware is able to complete data segmentation much faster than operating system software, this feature may improve transmission performance. In addition, the adapter uses fewer CPU resources.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Gigabit PHY Mode

Determines whether the adapter or link partner is designated as the primary. The other device is designated as the secondary device. Changing the setting may improve link quality with certain link partners.

CAUTION: Some multi-port devices may be forced to Primary Mode. If the adapter is connected to such a device and is configured to "Force Primary Mode", the device may either disconnect or downshift to a 100Mbps link. This may also occur in a "Forced Secondary" to "Forced Secondary" configuration. In short, forcing the adapter to the primary or secondary setting can break or downshift the link if the link partner is not configured correctly.
NOTE: Changing this setting may cause a momentary loss of connectivity.


Header Data Split

Enables the adapter to split the header information from an incoming packet so the CPU does not have to process the whole packet, reducing CPU utilization.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Hardware vRSS

Enables Receive Side Scaling (RSS) for virtual ports attached to a physical port. This allows RSS to be used on a VMQ virtual machine, and offloads the RSS processing to the network adapter. RSS balances receive traffic across multiple CPUs or CPU cores. This setting has no effect if your system has only one processing unit.


Interrupt Moderation

This sets the rate at which the controller moderates or delays the generation of interrupts making it possible to optimize network throughput and CPU utilization. The Adaptive setting adjusts the interrupt rates dynamically depending on traffic type and network usage. Choosing a different setting may improve network and system performance in certain configurations.

Without interrupt moderation, CPU utilization increases at higher data rates because the system must handle a larger number of interrupts. Interrupt moderation causes the network driver to accumulate interrupts and send a single interrupt rather than a series of interrupts. At higher data rates, a high interrupt moderation setting may improve system performance. At low data rates, a lower interrupt moderation setting is preferred as delayed interrupts causes latency.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Interrupt Moderation

Allows the adapter to moderate interrupts. When a packet arrives, the adapter generates an interrupt, which allows the driver to handle the packet. At greater link speeds, more interrupts are created, and CPU utilization also increases. This results in poor system performance. When you enable Interrupt Moderation, the interrupt rate is lower, and the result is better system performance.

NOTE: Changing this setting may cause a momentary loss of connectivity.


IPv4 Checksum Offload

Enables the adapter to verify the IP checksum on received packets and compute checksum on transmitted packets. Enabling this feature may improve IP performance and reduce CPU utilization.

NOTE: Changing this setting may cause a momentary loss of connectivity.


IP Checksum Offload v6

Enables the adapter to verify the IP checksum on received packets and compute checksum on transmitted packets. Enabling this feature may improve IP performance and reduce CPU utilization.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Jumbo Packets

Enables Jumbo Packet capability for TCP/IP packets. In situations where large packets make up the majority of traffic and additional latency can be tolerated, Jumbo Packets can reduce CPU utilization and improve wire efficiency.

NOTE: Changing this setting may cause a momentary loss of connectivity.

Usage Considerations

  • Enable Jumbo Packets only if devices across the network support them and are configured to use the same frame size. When setting up Jumbo Packets on other network devices, note that different network devices calculate Jumbo Packet sizes differently. Some devices include the header information in the frame size while others do not. Intel® Ethernet Adapters do not include header information in the frame size.
  • Using Jumbo Packets at 10 or 100 Mbps may result in poor performance or loss of link.
  • When configuring Jumbo Packets on a switch you may need to increase the frame size over the adapter's setting. Set the switch's frame size four bytes higher for Cyclic Redundancy Check (CRC), plus four bytes if you are using Virtual Local Area Networks (VLANs) or priority/VLAN tagging.


Locally Administered Address

Changes the MAC address used by this network adapter. The address is a 12-digit hexadecimal number in this range: 0000 0000 0001 - FEFF FFFF FFFF.

CAUTION: Make sure no other systems on the network use this address.

NOTES:

  • Do not use a multicast address (least significant bit of the high byte = 1).
    For example, in the address 0y123456789A, "y" cannot be an odd number. (y must be 0, 2, 4, 6, 8, A, C, or E.)
  • To restore the default MAC address, click Use Default.
  • You cannot change the address if any of the following is true:
    • The adapter is part of a team.
    • The adapter or team is bound to the Microsoft* Virtual Switch Protocol.
  • Changing this setting may cause a momentary loss of connectivity.


Advanced Tab - LAA not available

The Locally Administered Address (LAA) setting (details below) is currently disabled and cannot be changed because of one or more of the following conditions:

  • The device is part of a team.
  • The device or team is bound to the Microsoft* Virtual Switch Protocol.


Legacy Switch Compatibility Mode

Sets how link is established at 100Mbps and 10Mbps rates. When Enabled, the network connection will use the legacy "Forced" method to establish link. This can help to achieve link at the proper speed and duplex with some legacy switches. When Disabled, the network connection will use auto-negotiation to establish link at 100Mbps and 10Mbps speeds.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Link State on Interface Down

Sets if link is enabled or disabled when the interface is brought down. This setting is ignored and link will remain up if WoL or manageability is enabled on this device.


Log Link State

Enables the logging of link state changes to the system event log:

  • Network link has been established.
  • Network link has been lost.
  • There is a mismatch in duplex between the adapter and the link partner.

Troubleshooting tip: To investigate connection problems, click the Link Speed tab and run diagnostics.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Low Latency Interrupts

Enables adapters to bypass interrupt moderation and immediately generate an interrupt when certain TCP packets arrive, allowing the system to handle the packet more quickly. Certain applications will have faster access to network data because of the reduced data latency.

Disabled | Disables Low Latency Interrupts.
Port-Based: | Every packet received on the specified ports will trigger an immediate interrupt. Use the Low Latency Interrupt Ports setting to specify up to 8 ports.
PSH Flag Based: | Any incoming packet with the TCP PSH flag will trigger an immediate interrupt. The PSH flag is set by the sending device.
NOTE: Changing this setting may cause a momentary loss of connectivity.


Low Latency Interrupt Ports

Specify which TCP ports will trigger an interrupt. You may specify up to eight ports.

To remove a port from the list, select its checkbox and click the Remove Selected button.


Low Resource Connectivity

When this setting is enabled, the network adapter maintains network connectivity even if the system does not have enough resources to run all of the advanced settings, such as IPSec Offload and Large Send Offload. Advanced features resume only when you restart the computer.

To identify resource issues, check the system event log, which displays errors occurring as a result of low system resources.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Max Number of RSS Queues Per Vport

Sets the maximum number of Receive Side Scaling (RSS) queue pairs per VF.


Max RSS CPU

Sets the maximum number of logical processors available for Receive Side Scaling (RSS).


RSS MAX CPU Number

Sets the highest CPU number that can be used for RSS (Receive Side Scaling).


MDD Auto Reset VFs

Automatically resets the virtual function immediately after the physical device detects a Malicious Driver Detection (MDD) event on the receive path.


NetworkDirect Functionality

Allows the adapter to use Remote Direct Memory Access (RDMA).

NOTE: Devices based on the Intel® Ethernet 800 Series do not support RDMA when operating in multiport mode with more than 4 ports.


NetworkDirect Technology

Allows you to set the RDMA mode.

NOTES:
  • You must enable NetworkDirect Functionality for this setting to take effect.
  • Devices based on the Intel® Ethernet 800 Series do not support RDMA when operating in multiport mode with more than 4 ports.


NIC Partitioning

Enables NPAR on this device. NPAR allows you to create multiple partitions for each physical port on a network adapter card. To the network and operating system, each partition appears as a separate physical port on the adapter.

NOTE: A restart is required to implement NPAR setting changes.


Offload IP Security

Saves CPU cycles by offloading IPSec encryption from the CPU to the adapter.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Offload Receive TCP Checksum

Enables the adapter to verify the TCP or UDP checksum of incoming packets. This feature enhances receive performance and reduces CPU utilization.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Offload TCP Segmentation

Enables the adapter to offload the task of segmenting TCP messages into valid Ethernet frames. Because the adapter hardware is able to complete data segmentation much faster than operating system software, this feature may improve transmission performance. In addition, the adapter uses fewer CPU resources.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Offload Receive IP Checksum

Enables the adapter to verify the TCP/IP checksum on received packets and compute checksum on transmitted packets. Enabling this feature may improve TCP/IP performance.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Transmit IP Checksum

Enables the adapter to compute the IP checksum of transmitted packets. This feature may improve IP transmit performance and will reduce CPU utilization. With Offloading disabled, the operating system verifies the IP checksum.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Offload Transmit TCP Checksum

Enables the adapter to compute the TCP or UDP checksum of transmitted packets. This feature may improve TCP and UDP transmit performance and will reduce CPU utilization. With Offloading enabled, the adapter completes the verification for the operating system.

NOTES:
  • Disable this feature when the server is supporting DOS-based clients.
  • Changing this setting may cause a momentary loss of connectivity.


PCI Bus Efficiency

Combines transmit packet buffer fragments into a single buffer before sending them to the network.

  • When PCI Bus Efficiency is disabled, the adapter uses the transmission method that provides the best possible performance. If coalescing packets provides the best transmission performance, the adapter will automatically coalesce packets.
  • When PCI Bus Efficiency is enabled, the adapter forces packet coalescing.

Disable PCI Bus Efficiency if there are no problems with packet transmission performance. If there are a high number of underruns, or the PCI Bus exhibits performance problems, enable this setting.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Direct Cache Access

Direct Cache Access (DCA) reduces the number of memory access operations required to process each packet by delivering packet data directly to system CPU cache.

NOTES:
  • DCA is only available if the processor, chipset, and network device all support it.
  • Changing this setting may cause a momentary loss of connectivity.


DMA Coalescing

Sets an upper limit on the maximum amount of latency applied to any network packet due to Direct Memory Access (DMA) Coalescing. DMA Coalescing synchronizes the DMA activity across all of a NIC's ports, decreasing the system's power consumption. Higher values increase the power savings, but may add latency to network sessions. To optimize the power savings, this setting should be set to the same value for all ports on a NIC.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Low Latency Interrupts General

Enables adapters to bypass interrupt moderation and immediately generate an interrupt when certain TCP packets arrive, allowing the system to handle the packet more quickly. Certain applications will have faster access to network data because of the reduced data latency.

NOTES:
  • If this option is enabled, system CPU utilization may increase.
  • Changing this setting may cause a momentary loss of connectivity.


Low Latency Interrupts Properties

Configures which packets bypass interrupt moderation and trigger immediate interrupts.

Use for packets with TCP PSH flag: | Any incoming packet with the TCP PSH flag will trigger an immediate interrupt. The PSH flag is set by the sending device.
Use for these TCP ports: | Every packet received on the specified ports will trigger an immediate interrupt. Up to 8 ports may be specified.
NOTE: Changing this setting may cause a momentary loss of connectivity.


Preferred NUMA Node

Allows the user to choose the preferred non-Uniform Memory Access (NUMA) node to be used for memory allocations made by the network adapter. In addition the system will attempt to use the CPUs from the preferred NUMA node first for the purposes of Receive Side Scaling (RSS). On NUMA platforms, memory access latency is dependent on the memory location. Allocation of memory from the closest node helps improve performance. The Windows* Task Manager shows the NUMA Node ID for each processor.

NOTES:
  • This setting only affects NUMA systems. It will have no effect on non-NUMA systems.
  • Choosing a value greater than the number of NUMA nodes present in the system selects the NUMA node closest to the device.
  • NUMA node count begins at 0, not 1. For example, if you have three CPUs, you can select NUMA node 0, 1, or 2 as the preferred NUMA node.


Priority Level Definition

If the computer has 802.1p/802.1Q tagging (QoS) enabled, you can define the priority levels serviced by the priority queues. Intel® Ethernet Adapters have two priority queues: high and low. The number you specify sets the lower limit of the high priority queue.

For example, if you enter 6, packets with a priority of 0-5 are sent through the low priority queue, and packets with a value of 6-7 are sent through the high priority queue.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Priority & VLAN

This feature enables sending and receiving IEEE 802.3ac tagged frames.

  • Priority: 802.1p QoS (Quality of Service) tags for priority-tagged packets
  • VLAN: 802.1Q tags for Virtual Local Area Networks (VLANs)

Tagged packets use the queue settings defined by the operating system's Priority Level Definition.

Tagging is automatically enabled when you set up a VLAN on the VLAN tab. If you have a tagged VLAN set up, you will not be able to disable tagging.

NOTES:
  • Advanced Networking Services (ANS) must be installed to set up VLANs.
  • Changing this setting may cause a momentary loss of connectivity.
  • This setting cannot be modified from Packet Priority & VLAN Enabled if Data Center Bridging (DCB) is enabled.


Perfomance Profiles

Specifies the Profile for the adapter. Selecting a profile sets several Advanced options for optimal performance for that role.

  • Standard Server – This profile is optimized for typical servers.
  • Web Server – This profile is optimized for IIS and HTTP based web servers.
  • Virtualization Server – This profile is optimized for Microsoft’s Hyper-V virtualization environment.
  • Storage Server – This profile is optimized for iSCSI over DCB performance.
  • Storage + Virtualization – This profile is optimized for a combination of storage and virtualization requirements.
  • Low Latency – This profile is optimized to minimize network latency.
  • Custom Settings – One of the optimized settings has been changed from the Profile.
NOTE: Not all options are available on all adapter/operating system combinations.


QoS Packet Tagging

When this feature is enabled, tagged packets use the queue settings defined by the operating system's Priority Level Definition. QoS Packet Tagging is automatically enabled when you set up a VLAN on the VLAN tab.You cannot disable tagging because tagging is required for VLANs. Enables sending and receiving of IEEE 802.3ac tagged frames, which include

  • 802.1p QoS (Quality of Service) tags for priority-tagged packets
  • 802.1Q tags for Virtual Local Area Networks (VLANs)
NOTES:
  • Advanced Networking Services (ANS) must be installed to set up VLANs.
  • Changing this setting may cause a momentary loss of connectivity.


RDMA Maximum VFs Enabled

Sets the maximum number of Virtual Functions (VFs) bound to this port that support RDMA.

NOTES:

  • You must match this setting across all ports.
  • You can bind more VFs to the port than specified by this setting. Additional VFs will not be capable of RDMA, but will otherwise function normally.
  • Devices based on the Intel® Ethernet 800 Series do not support RDMA when operating in multiport mode with more than 4 ports.


RDMA VF Resource Profile

Allocates a minimal number of RDMA resources (Queue Pairs, Completion Queues, etc.) to the host physical function (PF) so that more resources are available for any bound virtual function (VF).

NOTE: Devices based on the Intel® Ethernet 800 Series do not support RDMA when operating in multiport mode with more than 4 ports.


Retransmit Inter-Frame Spacing

Increases the delay between frame retransmissions. Although there is a built-in Ethernet algorithm that adapters use for retransmitting frames after collisions, increasing the delay can improve network performance if there is an abnormally large number of collisions on the network.

NOTE: Changing this setting may cause a momentary loss of connectivity.


RSS

Enables Receive Side Scaling (RSS). RSS balances receive traffic across multiple CPUs or CPU cores. This setting has no effect if your system has only one processing unit.

NOTES:
  • RSS is not supported on some adapters configured to use Virtual Machine Queues (VMQ). On these adapters VMQ will take precedence over RSS. RSS will appear disabled.
  • Changing this setting may cause a momentary loss of connectivity.

Teaming Notes

  • If RSS is not enabled for all adapters in a team, RSS will be disabled for the team.
  • If an adapter that does not support RSS is added to a team, RSS will be disabled for the team.
  • If a non-Intel adapter is added to a team, its RSS settings must match the Intel adapters in the team.
  • Not all adapters support all RSS queue settings.


Receive Side Scaling Profile

Configures how the Receive Side Scaling (RSS) load is balanced across the available processors.

  • Closest Processor - Dynamically balances the RSS load across the available processors. This scales as the RSS load increases or decreases.
  • Closest Processor Static - Assigns the processors, but does not scale as the RSS load changes.
  • NUMA Scaling - Dynamically assigns processors in a round robin across the available non-Uniform Memory Access (NUMA) nodes. This scales as the RSS load increases or decreases.
  • NUMA Scaling Static - Assigns processors across the available NUMA nodes, but does not scale as the RSS load changes.
  • Conservative Scaling - Analyzes the RSS load and assigns the fewest number of processor to sustain the load.


Receive Side Scaling Queues

Configures the number of Receive Side Scaling (RSS) queues:

  • 1 queue is used when low CPU utilization is required.
  • 2 queues is used when good throughput and low CPU utilization are required.
  • Four or more queues are used for applications that demand high transaction rates such as web server based applications. Your CPU utilization may be higher when you use four or more queues.
NOTES:
  • Not all adapters support all RSS queue settings.
  • RSS is not supported on some adapters configured to use Virtual Machine Queues (VMQ). On these adapters VMQ will take precedence over RSS. RSS will appear disabled.
  • Changing this setting may cause a momentary loss of connectivity.


Receive Buffers

Sets the number of Receive Buffers used by the adapter when copying data to memory. Increasing this value can enhance receive performance, but also consumes system memory.

You might choose to increase the number of Receive Buffers if you notice a significant decrease in the performance of received traffic. If receive performance is not an issue, use the default setting.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Receive Descriptors

Sets the number of Receive Descriptors used by the driver when copying data to the protocol memory. Increasing this value can enhance receive performance, but also consumes system memory.

Receive Descriptors are data segments that enable the adapter to allocate received packets to memory. Each received packet requires one Receive Descriptor, and each descriptor uses 2KB of memory.

You might choose to increase the number of Receive Descriptors if you notice a significant decrease in the performance of received traffic. If receive performance is not an issue, use the default setting.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Rollback Mode

This port is in firmware rollback mode. It may have reduced functionality. Usually this occurs when a firmware update does not complete correctly. Rebooting or power cycling the system may allow the port to use the previous firmware. You may need to reapply the firmware update. Refer to the Intel® Ethernet Adapters and Devices User Guide for details on firmware rollback mode.


Safe Mode

This driver is in safe mode. Safe mode supports only minimal functionality and disables advanced and performance features. Refer to the Intel® Ethernet Adapters and Devices User Guide for details on safe mode.


Security Associations

Specifies the number of simultaneous Security Associations that can be offloaded to the adapter. A security association is a communication session with another computer running IP Security software.

If the computer is capable of supporting more Security Associations than what is specified as the default, increase this value. NOTE that increasing the number of Security Associations increases the memory consumption of the adapter.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Smart Speed

Enables the device downshift the link speed if the connection is of insufficient quality to support the highest speed. Set to disable if you don't want the device to downshift its link speed.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Starting RSS CPU

Allows the user to set the preferred starting Receive Side Scalling (RSS) processor. Change this setting if the current processor is dedicated to other processes. The setting range is from 0 to the number of logical CPUs - 1.


TCP Checksum Offload (IPv4)

Enables the adapter to verify the TCP checksum on received packets and compute checksum on transmitted packets. Enabling this feature may improve TCP performance and reduce CPU utilization.

NOTE: Changing this setting may cause a momentary loss of connectivity.


TCP Checksum Offload v6

Enables the adapter to verify the TCP checksum on received packets and compute checksum on transmitted packets. Enabling this feature may improve TCP performance and reduce CPU utilization.

NOTE: Changing this setting may cause a momentary loss of connectivity.


TCP Receive Segment Coalescing - IPv4

Enables the adapter to collect packets from a TCP/IP stream and combine them into larger packets.


TCP Receive Segment Coalescing - IPv6

Enables the adapter to collect packets from a TCP/IP stream and combine them into larger packets.


Transmit Buffers

Sets the number of Transmit Buffers used by the adapter when copying data to memory. Increasing this value can enhance transmission performance, but also consumes system memory.

You might choose to increase the number of Transmit Buffers if you notice a significant decrease in the performance of transmitted traffic. If transmission performance is not an issue, use the default setting.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Transmit Descriptors

Defines the number of Transmit Descriptors, which are data segments that enable the adapter to track transmit packets in the system memory. Depending on the size of the packet, each transmit packet requires one or more Transmit Descriptors.

You might choose to increase the number of Transmit Descriptors if you notice a problem with transmit performance. Increasing the number of Transmit Descriptors can enhance transmit performance. However, Transmit Descriptors consume system memory. If transmit performance is not an issue, use the default setting.

NOTE: Changing this setting may cause a momentary loss of connectivity.


UDP Checksum Offload (IPv4)

Enables the adapter to verify the UDP checksum on received packets and compute checksum on transmitted packets. Enabling this feature may improve UDP performance and reduce CPU utilization.

NOTE: Changing this setting may cause a momentary loss of connectivity.


UDP Checksum Offload v6

Enables the adapter to verify the UDP checksum on received packets and compute checksum on transmitted packets. Enabling this feature may improve UDP performance and reduce CPU utilization.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Virtualization

Configures the device for use with virtualization and displays virtualization statistics.


Virtualization - No Hyper-V

The virtualization settings are not available because Microsoft* Hyper-V* has not been installed on the system.


Virtualization Dialog

Enable Virtual Machine Queues: Enables Virtual Machine Queue (VMQ) Filter offloading. This offloads the filtering of receive and transmit traffic for each virtual machine into the adapter hardware. Filtering is based on MAC and/or VLAN filters. This increases receive and transmit performance, as the adapter hardware is able to perform these tasks faster than the operating system. Offloading also frees up CPU resources.

NOTES:
  • Enabling this setting will enable VMQ on Microsoft's VM switch.
  • Changing this setting may cause a momentary loss of connectivity.

Enable SR-IOV: Enables SR-IOV (Single Root I/O Virtualization). This allows any attached virtual machine bound to the device to bypass the operating system's virtual switch and access the device directly. This setting is grayed out if Enable Virtual Machine Queues is not selected.

NOTE: In a virtualized environment, on Intel® Server Adapters that support SR-IOV, the virtual function (VF) may be subject to malicious behavior. Software-generated frames are not expected and can throttle traffic between the host and the virtual switch, reducing performance. To resolve this issue, configure all SR-IOV enabled ports for VLAN tagging. This configuration allows unexpected, and potentially malicious, frames to be dropped.

Teaming Considerations

  • If VMQ is not enabled for all adapters in a team, VMQ will be disabled for the team.
  • If an adapter that does not support VMQ is added to an existing team, VMQ will be disabled for the team.
  • If SR-IOV is enabled on a device, and a virtual NIC is bound to that device, the device cannot be a part of a team.

Current Virtualization Status

Type | The type of the VPort.
VPort ID | The unique ID assigned by the operating system.
CPU ID | The logical processor associated with the VPort.
Rx Packets | The number of packets received by the VPort.
Tx Packets | The number of packets sent by the VPort.


Virtualization Dialog - NPAR and SR-IOV Configuration

Enable Virtual Machine Queues: Checking this box enables Virtual Machine Queue (VMQ) Filter offloading. This offloads the filtering of receive and transmit traffic for each virtual machine into the adapter hardware. Filtering is based on MAC and/or VLAN filters. This increases receive and transmit performance, as the adapter hardware is able to perform these tasks faster than the operating system. Offloading also frees up CPU resources.

NOTES:
  • Enabling this setting will enable VMQ on Microsoft's VM switch.
  • Changing this setting may cause a momentary loss of connectivity.

Enable SR-IOV: Checking this box enables SR-IOV (Single Root I/O Virtualization). This allows any attached virtual machine bound to the device to bypass the operating system's virtual switch and access the device directly. If SR-IOV is disabled in firmware, enabling this setting will require a system restart.

NOTE: In a virtualized environment, on Intel® Server Adapters that support SR-IOV, the virtual function (VF) may be subject to malicious behavior. Software-generated frames are not expected and can throttle traffic between the host and the virtual switch, reducing performance. To resolve this issue, configure all SR-IOV enabled ports for VLAN tagging. This configuration allows unexpected, and potentially malicious, frames to be dropped.

VPort Availability: Sets the distribution of VPorts assigned to VMQ and SR-IOV. You should modify this setting depending on the expected operating system of your client virtual machines. If most of the clients do not support SR-IOV, weight it towards VMQ.

Teaming Considerations:

  • If VMQ is not enabled for all adapters in a team, VMQ will be disabled for the team.
  • If an adapter that does not support VMQ is added to an existing team, VMQ will be disabled for the team.
  • If SR-IOV is enabled on a device, and a virtual NIC is bound to that device, the device cannot be a part of a team.

Current Virtualization Status:

Type | The type of the VPort.
VPort ID | The unique ID assigned by the operating system.
CPU ID | The logical processor associated with the VPort.
Rx Packets | The number of packets received by the VPort.
Tx Packets | The number of packets sent by the VPort.


Virtualization Dialog - No SR-IOV

Enable Virtual Machine Queues: Checking this box enables Virtual Machine Queue (VMQ) Filter offloading. This offloads the filtering of receive and transmit traffic for each virtual machine into the adapter hardware. Filtering is based on MAC and/or VLAN filters. This increases receive and transmit performance, as the adapter hardware is able to perform these tasks faster than the operating system. Offloading also frees up CPU resources.

NOTES:
  • Enabling this setting will enable VMQ on Microsoft's VM switch.
  • Changing this setting may cause a momentary loss of connectivity.

Teaming Considerations

  • If VMQ is not enabled for all adapters in a team, VMQ will be disabled for the team.
  • If an adapter that does not support VMQ is added to an existing team, VMQ will be disabled for the team.

Current Virtualization Status

Type | The type of the VPort.
VPort ID | The unique ID assigned by the operating system.
CPU ID | The logical processor associated with the VPort.
Rx Packets | The number of packets received by the VPort.
Tx Packets | The number of packets sent by the VPort.


Virtualization Dialog - SR-IOV capable

Enable Virtual Machine Queues: Checking this box enables Virtual Machine Queue (VMQ) Filter offloading. This offloads the filtering of receive and transmit traffic for each virtual machine into the adapter hardware. Filtering is based on MAC and/or VLAN filters. This increases receive and transmit performance, as the adapter hardware is able to perform these tasks faster than the operating system. Offloading also frees up CPU resources.

NOTES:
  • Enabling this setting will enable VMQ on Microsoft's VM switch.
  • Changing this setting may cause a momentary loss of connectivity.

Enable SR-IOV: Checking this box enables SR-IOV (Single Root I/O Virtualization). This allows any attached virtual machine bound to the device to bypass the operating system's virtual switch and access the device directly. This setting is grayed out if Enable Virtual Machine Queues is not selected.

NOTE: In a virtualized environment, on Intel® Server Adapters that support SR-IOV, the virtual function (VF) may be subject to malicious behavior. Software-generated frames are not expected and can throttle traffic between the host and the virtual switch, reducing performance. To resolve this issue, configure all SR-IOV enabled ports for VLAN tagging. This configuration allows unexpected, and potentially malicious, frames to be dropped.

VPort Availability: Sets the distribution of VPorts assigned to VMQ and SR-IOV. You should modify this setting depending on the expected operating system of your client virtual machines. If most of the clients do not support SR-IOV, weight it towards VMQ.

Teaming Considerations:

  • If VMQ is not enabled for all adapters in a team, VMQ will be disabled for the team.
  • If an adapter that does not support VMQ is added to an existing team, VMQ will be disabled for the team.
  • If SR-IOV is enabled on a device, and a virtual NIC is bound to that device, the device cannot be a part of a team.

Current Virtualization Status:

Type | The type of the VPort.
VPort ID | The unique ID assigned by the operating system.
CPU ID | The logical processor associated with the VPort.
Rx Packets | The number of packets received by the VPort.
Tx Packets | The number of packets sent by the VPort.


VLAN ID

Select the number for the VLAN bound to this device. The VLAN ID must match the VLAN ID configured on the switch. Adapters with VLANs must be connected to network devices that support IEEE 802.1Q. Note that if you enter a value greater than the maximum value of 4094 then VLAN ID 4094 will be assigned to this device.


Wait for Link

Determines whether the driver waits for automatic detection or negotiation to be successful before reporting the link state.

Options

Off: Driver does not wait for automatic detection or negotiation.

On: Driver does wait for automatic detection or negotiation. If the adapter is not set to automatically detect or negotiate speed, the driver waits for a short time for link to complete and then reports the link state.

Auto Detect: Automatically set to On or Off depending on speed and adapter type when the driver is installed.

  • Off for copper Intel Gigabit adapters set to automatically detect or negotiate speed.
  • On for copper Intel Gigabit adapters set to force speed and duplex.
  • On for fiber Intel Gigabit adapters.
NOTE: Changing this setting may cause a momentary loss of connectivity.


This network connection is disabled

This network connection is disabled or has been removed from the system. You must reinstall the connection or enable it from the General tab before you can access disabled features.

NOTES:

  • If you disable all assigned virtual local area networks (VLANs) on a team, the New button for creating VLANs becomes inactive (grayed out). But if just one VLAN is left enabled and the rest are disabled, the New button remains active. On a stand-alone adapter, the New button is always active regardless of VLAN status. For more information on VLANs, see the VLAN Overview.
  • Legacy iSCSI Boot and CLP images are not supported and cannot be loaded or configured.


NIC Partition Bandwidth Configuration

Select a partition to configure the minimum and maximum bandwidth available for that partition. Valid Minimum Bandwidth Percentages values range from 1 to (100 minus (# of partitions on the physical port) plus 1). For example, if a physical port has 4 partitions, the range would be 1 to (100 - 4 + 1 = 97). The Minimum Bandwidth Percentages must add up to 100% (for example, 97 + 1 + 1 + 1 = 100). Maximum Bandwidth Percentages can be set to any amount between the Minimum Bandwidth Percentage and 100% .

The Minimum Bandwidth Percentage is a guarantee of availability. If only one partition is sending/receiving, it can use all of the physical port's bandwidth (up to the partition's Maximum Bandwidth Percentage setting). If a second partition starts to send/receive, the first partition will slow down until the second partition reaches its Minimum Bandwidth Percentage. The partitions will split any remaining bandwidth.


Intel Multi-Speed Link Page

Speed and Duplex Setting: By default, Intel® Ethernet devices are set to automatically detect and negotiate speed and duplex. A setting other than Auto Negotiation restricts what the device advertises during auto-negotiation.

SFP+ Modules:

Some SFP+ Modules do not support all speeds that the Intel adapter is capable of. Only speeds that the adapter/module combination is capable of are displayed in the drop down menu.

EEE Enabled: "EEE Enabled" is displayed if this device has negotiated an Energy Efficient Ethernet link with its link partner.

Temperature: Displays the temperature state if the adapter has a temperature sensor.

NOTE: If you select a speed that the link partner does not support, the adapter will attempt to connect at a different speed, rather than drop link. This may result in a mismatch between the Speed and Duplex setting and the Link Status.

Copyright, legal disclaimers, and support information


Intel Single-Speed Link Page

This device's link speed is dependent on the device's link partner. You cannot change the speed setting.

EEE Enabled: "EEE Enabled" is displayed if this device has negotiated an Energy Efficient Ethernet link with its link partner.

Temperature: Displays the temperature state if the adapter has a temperature sensor.

Copyright, legal disclaimers, and support information


NPAR Link Page

Speed and Duplex: By default, Intel® adapters are set to automatically detect and negotiate speed and duplex. If the adapter fails to connect, you can set the Speed and Duplex setting to match those of the link partner. The Auto-negotiate 1000Mbps setting sets the adapter to advertise only that speed during auto-negotiation.

Information icon

This icon is displayed when the device is not linked at its maximum capable speed. In that case, if your device is set to auto-negotiate, you can adjust the speed of the device's link partner to the device's maximum speed. If the device is not set to auto-negotiate, you can adjust the device's speed manually, but you must ensure the link partner is set at the same speed.

NOTES:

  • Changing the Speed and Duplex setting on this partition will change the setting for all partitions bound to same physical port.
  • Changing this setting will cause a momentary loss of connectivity for all partitions bound to the same physical port.

Temperature: Displays temperature state if the adapter has a temperature sensor.

Bandwidth Configuration: Configures NIC Partitioning bandwidth for the adapter.

Copyright, legal disclaimers, and support information


Power Management Tab

The options on this tab extend the capabilities of the standard Power Management options. Highlighting an option will display help information on that option. Power Saver Options determine when and how the adapter reduces power consumption. Wake on LAN options allow you to specify which events will wake the computer.

Unless Wake on LAN options are enabled, Intel® adapters always allow the computer to power down the device when the computer is hibernating or in standby.


Auto Connect Battery Saver (ACBS)

Enables the Intel® Auto Connect Battery Saver (Intel® ACBS) feature. This turns off the adapter when link is down or the network cable is disconnected. After a timeout period, the adapter will power off.

When the network cable is reconnected and link is restored, the NIC powers up and functionality is fully restored.

NOTES:

  • This feature only works when the system is on battery power. If the power cable is connected, Intel® ACBS will be automatically disabled.
  • Intel® ACBS will not function on an adapter if the adapter has forced speed or duplex settings. Intel® ACBS will only function if the adapter is set to automatically detect or negotiate speed and duplex.
  • ACBS will not be activated if your system enters a low power state (standby, hibernate, or power down) with the LAN cable still connected. To activate ACBS, disconnect the LAN cable and wait at least 15 seconds before putting your system into a low power state.


Enable ARP Offload

Sets the adapter to respond to ARP requests without waking the system from sleep or hibernate. The system can remain in sleep or hibernate mode and still maintain its network presence.


Deep Smart Power Down

Turns off the adapter when link is down or the network cable is disconnected. After a timeout period, the adapter will power off. To the operating system, this appears as a hot-unplugged adapter. When the network cable is reconnected and link is restored, the NIC powers up and functionality is fully restored. This appears as a hot-plugged adapter.


Power Management Tab, Energy Efficient Ethernet

Enables Energy Efficient Ethernet (EEE). EEE allows this device to transmit and receive packets with minimal bursts of energy and enter a low power state when idle.

NOTE: Both ends of the link must have EEE enabled for this setting to be effective.


Enhanced ASPM

Saves power when the adapter is active by entering the L1 PCI Express low-power link state when there are no outstanding requests or pending transactions.


Power Management Tab, No Power Saver Options

The options on this tab extend the capabilities of the standard Power Management options. Highlighting an option will display help information on that option. Wake on LAN options allow you to specify which events will wake the computer.

Unless Wake on LAN options are enabled, Intel® Network Adapters always allow the computer to power down the device when the computer is hibernating or in standby.

This port does not support Power Saver Options.


Power Management Tab, No WoL Options

The options on this tab extend the capabilities of the standard Power Management options. Highlighting an option will display help information on that option. Power Saver Options determine when and how the adapter reduces power consumption.

This port does not support Wake on LAN options.


Boot Tab unavailable - NPAR

 The underlying device for this connection has NIC Paritioning enabled. Power Management options can only be configured on the first partition of the physical port. Click the Properties button to open the Property Sheet for the first partition.


Enable NS Offload

Sets the adapter to respond to NS requests (NS requests are the IPv6 equivalent of ARP requests) without waking the system from sleep or hibernate. The system can remain in sleep or hibernate mode and still maintain its network presence.


Reduce Power When on Battery Power

Enables the Intel® Link Speed Battery Saver feature. Sets the adapter to negotiate the lowest possible speed setting while the computer is on battery power.

To support this feature, the adapter must be:

  • configured to automatically detect or negotiate speed.
  • connected to a link partner that can automatically negotiate speed.


Reduce Power When the Cable is Disconnected

Sets the adapter to reduce power consumption when the network cable is disconnected from the adapter or when the operating system is in Suspend mode. When the adapter regains a valid link, adapter power usage returns to its normal state (full power usage).

NOTE: When two Intel® PRO/1000 MT Desktop Adapters are connected back to back and this feature is enabled, there is no link between these adapters. You must disable this feature on both adapters when connecting them back to back.


Reduce Speed to Save Power

Enables the Intel® System Idle Power Saver feature. Sets the adapter to negotiate the lowest possible speed setting when the system and network is idle.

To support this feature, the adapter must be:

  • configured to automatically detect or negotiate speed.
  • connected to a link partner that can automatically negotiate speed.


Reduce Speed on Power Down

Sets the adapter to negotiate the lowest possible speed setting to save power while the computer is shut down.

To support this feature, the adapter must be:

  • configured to automatically detect or negotiate speed.
  • connected to a link partner that can automatically negotiate speed.


Reduce Speed to Save Power

Sets the adapter to negotiate the lowest possible speed setting to conserve power.

To support this feature, the adapter must be:

  • configured to automatically detect or negotiate speed.
  • connected to a link partner that can automatically negotiate speed.
NOTES: Intel® Gigabit adapters must be connected to a switch to use this feature.


Reduce Power During Standby

Sets the adapter to negotiate the lowest possible speed setting to save power while the computer is in standby mode.

NOTES:

  • Wake on Magic Packet or Wake on Directed Packet must be enabled for this option to function.
  • Wake on Magic Packet from power off state has no effect on this option.

To support this feature, the adapter must be:

  • configured to automatically detect or negotiate speed.
  • connected to a link partner that can automatically negotiate speed.


SelectiveSuspend

Enables the device to enter a low power state when the network is idle.


SSIdleTimeout

Sets the length of time that the network is idle before the device enters a low power state. You must enable Selective Suspend for this setting to take effect.


Sleep on Disconnect

Sets the adapter to reduce power consumption when the network cable is disconnected from the adapter. When the adapter regains a valid link, adapter power usage returns to its normal state (full power usage).


Ultra Low Power Mode

Enabling Ultra Low Power (ULP) mode significantly reduces power consumption when the network cable is disconnected from the device.

NOTE: If you experience link issues when two ULP-capable devices are connected back to back, disable ULP mode on one of the devices.


Wake From S5

Allows the adapter to wake an Advanced Power Management (APM) enabled system from a power-off (S5) state. ACPI systems can wake from an S5 state if the system's BIOS supports it.


Wake on Directed Packet

Enables this device to bring the computer out of standby or hibernation when it detects a packet with a specific pattern. The specific patterns are determined by the operating system.


Wake On Link

Allows the adapter to wake an Advanced Power Management (APM) enabled system when the network connection establishes link. ACPI (Advanced Configuration and Power Interface) systems can wake from Standby (S3) or Hibernate (S4). If the system's BIOS supports it, ACPI systems can wake from a Power-off (S5) state.

NOTES:

  • To wake from S5, you must enable the Wake on Magic Packet from power off state setting.
  • Link must be lost before the system enters an S5 state in order to wake the system with a link up event.
  • You must enable Wake on Magic Packet or Wake on Pattern Match for Wake on Link to function properly.


Wake On Magic Packet

Enables a management station to bring the computer out of standby or hibernation when a Magic Packet* is sent directly to the adapter.


Modern Standby WoL Magic Packet

Enables this device to bring the system out of the S0ix power state when the device receives a Magic Packet* .


Wake on Ready Access

Intel® Remote Wake Technology keeps your network connection active when the rest of your system is in sleep or standby mode, so that content on your system is readily accessible. Requests from other computers will wake up your computer.


Advanced Settings TOC

Advanced Settings

Jumbo Packets

Locally Administered Address

Log Link State Event

Performance Options

Adaptive Inter-Frame Spacing

Direct Cache Access

Flow Control

Interrupt Moderation Rate

Low Latency Interrupts

Low Latency Interrupts Properties

Receive Descriptors

PRO100 Receive Descriptors

Transmit Descriptors

PRO100 Transmit Descriptors

Receive Buffers

Transmit Buffers

QoS Packet Tagging

TCP/IP Offloading Options

Offload Receive IP Checksum

Offload Receive TCP Checksum

Offload Transmit IP Checksum

Offload Transmit TCP Checksum

Offload TCP/IP Checksum

Offload TCP Segmentation

Offload IP Security

Wait for Link


Configuring Settings status page

Configuring. Please wait . . .


Flow Control Overview

A link partner can become overloaded if incoming frames arrive faster than the device can process them, and this results in the frames being discarded until the overload condition passes. The flow control mechanism overcomes this problem and eliminates the risk of lost frames.

If a potential overload situation occurs, the device generates a flow control frame, which forces the transmitting link partner to immediately stop transmitting and wait a random amount of time before trying to retransmit.


Legal Information

Copyright and Legal Disclaimers

Copyright © 2004 - 2023 Intel Corporation. All rights reserved.

This software and the related documents are Intel copyrighted materials, and your use of them is governed by the express license under which they were provided to you ("License"). Unless the License provides otherwise, you may not use, modify, copy, publish, distribute, disclose or transmit this software or the related documents without Intel's prior written permission.

This software and the related documents are provided as is, with no express or implied warranties, other than those that are expressly stated in the License.

Intel technologies may require enabled hardware, software or service activation.

No product or component can be absolutely secure.

Intel, the Intel logo, and other Intel marks are trademarks of Intel Corporation or its subsidiaries.

*Other names and brands may be claimed as the property of others.

Back


Intel 10GbE Link Page

Some Intel® 10GbE adapters can operate at both 10Gbps and 1Gbps. The link speed is dependent on the adapter’s link partner. You cannot change the speed setting for these adapters.

Information icon

This icon is displayed when the device is not linked at its maximum capable speed. In that case, if your device is set to auto-negotiate, you can adjust the speed of the device's link partner to the device's maximum speed. If the device is not set to auto-negotiate, you can adjust the device's speed manually, but you must ensure the link partner is set at the same speed.

Copyright, legal disclaimers, and support information


Intel 10GbE Link Page

Speed and Duplex Setting: By default, Intel® adapters are set to automatically detect and negotiate speed and duplex settings. A setting other than Auto Negotiation restricts what the adapter advertises during auto-negotiation.

Information icon

This icon is displayed when the device is not linked at its maximum capable speed. In that case, if your device is set to auto-negotiate, you can adjust the speed of the device's link partner to the device's maximum speed. If the device is not set to auto-negotiate, you can adjust the device's speed manually, but you must ensure the link partner is set at the same speed.

Temperature: Displays temperature state if the adapter has a temperature sensor.

SFP+ Modules:

Some SFP+ Modules do not support all speeds that the Intel adapter is capable of. Only speeds that the adapter/module combination is capable of will be displayed in the drop down menu.

NOTES:

  • If you select a speed that the link partner does not support, the adapter will attempt to connect at a different speed, rather than drop link. This may result in a mismatch between the Speed and Duplex setting and the Link Status.

Copyright, legal disclaimers, and support information


Intel Gigabit Link Page

Speed and Duplex Setting: By default, Intel® adapters are set to automatically detect and negotiate speed and duplex settings. If the adapter fails to connect, you can set the speed and duplex settings to match those of the link partner. The Auto-negotiate 1000Mbps setting sets the adapter to advertise only that speed during auto-negotiation.

Information icon

This icon is displayed when the device is not linked at its maximum capable speed. In that case, if your device is set to auto-negotiate, you can adjust the speed of the device's link partner to the device's maximum speed. If the device is not set to auto-negotiate, you can adjust the device's speed manually, but you must ensure the link partner is set at the same speed.

EEE Enabled: "EEE Enabled" is displayed if this device has negotiated an Energy Efficient Ethernet link with its link partner.

Temperature: Displays temperature state if the adapter has a temperature sensor.

Copyright, legal disclaimers, and support information


Intel Gigabit Fiber Link Page

Intel® Gigabit fiber and SerDes devices operate at 1 Gbps. You cannot change the speed and duplex settings for this type of adapter.

Information icon

This icon is displayed when the device is not linked at its maximum capable speed. In that case, if your device is set to auto-negotiate, you can adjust the speed of the device's link partner to the device's maximum speed. If the device is not set to auto-negotiate, you can adjust the device's speed manually, but you must ensure the link partner is set at the same speed.

Copyright, legal disclaimers, and support information


Intel Gigabit Link Page

Speed and Duplex Setting: By default, Intel® adapters are set to automatically detect and negotiate speed and duplex settings. If the adapter fails to connect, you can set the speed and duplex settings to match those of the link partner.

Information icon

This icon is displayed when the device is not linked at its maximum capable speed. In that case, if your device is set to auto-negotiate, you can adjust the speed of the device's link partner to the device's maximum speed. If the device is not set to auto-negotiate, you can adjust the device's speed manually, but you must ensure the link partner is set at the same speed.

EEE Enabled: Displays "EEE Enabled" if this device has negotiated an Energy Efficient Ethernet link with its link partner.

Temperature: Displays temperature state if the adapter has a temperature sensor.

Copyright, legal disclaimers, and support information


Support

Internet sites:

Customer Support:

http://www.intel.com/support

Network Products:

http://www.intel.com/content/www/us/en/ethernet-controllers/ethernet-products.html

Download Site:

http://downloadcenter.intel.com/

Copyright and Legal Disclaimers

Copyright © 2004 - 2023 Intel Corporation. All rights reserved.

*Other names and brands may be claimed as the property of others.

Intel Corporation assumes no responsibility for errors or omissions in this document. Nor does Intel make any commitment to update the information contained herein.

Intel is a trademark of Intel Corporation in the U.S. and other countries.


Flow Control Settings

Enables adapters to generate or respond to flow control frames, which help regulate network traffic.For an overview of this feature, click here.

Respond | The adapter pauses transmission when it receives a flow control frame from a link partner.
Generate | The adapter generates a flow control frame when its receive queue reaches a pre-defined limit.
Generate and Respond | The adapter generates and responds to flow control frames.
Off | The adapter does not generate or respond to flow control frames.

NOTES:

  • For adapters to benefit from this feature, link partners must support flow control frames.
  • Changing this setting may cause a momentary loss of connectivity.


VLAN Overview

A Virtual LAN (VLAN) is a logical grouping of hosts, allowing them to communicate as if they were on the same LAN, regardless of the network's physical topology. An adapter or team can support up to 64 VLANs.

VLAN types

There are two basic types of VLANs: Tagged VLANs and Untagged or Port-based VLANs.

  • Tagged VLANs are based on the IEEE 802.1Q specification. Each packet has a four-byte tag added to the packet header. The switch must support IEEE 802.1Q tagging and be properly configured. Check your switch documentation for the correct switch configuration.
  • Untagged or port-based VLANs are statically configured on the switch. They are transparent to connected devices.

NOTE: In a virtualized environment, on Intel® Server Adapters that support SR-IOV, the virtual function (VF) may be subject to malicious behavior. Software-generated frames are not expected and can throttle traffic between the host and the virtual switch, reducing performance. To resolve this issue, configure all SR-IOV enabled ports for VLAN tagging. This configuration allows unexpected, and potentially malicious, frames to be dropped.